Ramblings From The Litter Tray of Life

Posts Tagged ‘gpo’

Deploying AutoCAD 2010 via GPO (Part 4)

Posted by graycat on 10 June 2009

Or  Death by Application Rollout!

Now that I’m into the testing phase on live machines, all manner of lovely issues seem to crop up. Here’s some of the major ones and how to resolve them.

FATAL ERROR: Unhandled e0434f4dh Exception at 7c812a5bh

This is related to the .NET installs on the local machine. The latest version I have allowed here is 3.5 SP1 and there seems to have been issues with the initial release from MS. A quick an easy resolution to this is to uninstall the SP1, reboot the machine and let it pick up the updated SP1 from WSUS or wherever. In all the cases I’ve had here, this has resolved the issue nicely.

Various DLL, cui / cuix and chm files missing

This was a tough one to figure out but it seems for some reason that the msi package doens’t copy all the dll files down from the install point. To resolve this, I added a start up script to the policy like this:

REM     check if done previously
if exist “c:\Program Files\AutoCAD 2010\dllsynch.flg” exit else
goto copy

:copy
REM    synchronise dll files from install point
start /wait xcopy /d/e/h/c/y “\\domain\dfs\it\Deployment\ACAD2010_Fixed\AdminImage\x86\acad\en-us\Acad\Program Files\Root” “c:\Program Files\AutoCAD 2010\”

REM    create dllsynch.flg to prevent rerun.
echo done > “c:\Program Files\AutoCAD 2010\dllsynch.flg”

Exit

As you can tell I’ve added a bit more into it to synchronise the whole directory. At first it was just the dll files but there was a later issue involving chm and cuix files. No idea why these files don’t make it down to the computer but this seemed to resolve various issues.

New Features Workshop

This was due to missing chm files in the install directory. The script sorted that one out.

Missing acad.chm

This is the help menu which I’m told could be pretty useful and fortunately it’s a simple missing chm file. Thankfully, the script (I’m beginning to think it needs a proper name!) sorted this one out again.

Well, second round of installs is tomorrow so we’ll see how things go. Watch this space as they say. 😉

Advertisements

Posted in IT | Tagged: , , , , , , , , , , | Leave a Comment »

Deploying AutoCAD 2010 via GPO (Part 2)

Posted by graycat on 9 June 2009

Carrying on from my previous post on deploying AutoCAD 2010 via GPO here’s an update with the latest problems and solutions I’ve run into.

AutoCAD LT  deploys fine now. I think after the scripted installs had finished doing their thing, it was happy. Since then all the deployments have gone through fine including those on live machines. Now it’s all down to the CAD guys to let me know how it works.

I’ve since rolled up my sleeves and am taking a swing at the bigger one with the full fixed licence install.

The installation package went up to the server / dfs share fine as you would expect but my god it’s huge! 1.4Gb to be slightly more accurate!! Ok, so that is with all the packages included but it’s still a touch large in my opinion. The price of progression and all that.

So post package upload I was looking through it and it claims to have the C++ package embedded so I decided to leave my own package off at this point and see how it rolls. I created the new GPO, security group, wiped the test rig and linked it all together.

Unfortunately it failed.

DirectX – error message  saying “must install DirectX first” was he only indicator which was a bit frustrating as DirectX was already installed! A quick test using “dxdiag” confirmed it was there but the install package was just not having it.

Looking into deploying DirectX showed some interesting approaches out there. A quick try of a few and the most reliable one was using the web setup. To do this you need to download the dwebsetup.exe from Microsoft and then setup a nice startup script to actually run the install. Here’s mine:

REM    Check if dxwebsetup.exe exists already
if exist %windir%\system32\DirectX\DXWebSetup.exe exit else

REM     make folder and copy down base installer
md %windir%\system32\DirectX

xcopy /c/y \\domain\dfs\it\deployment\directx\dxwebsetup.exe %windir%\system32\DirectX\

REM     install DirectX
%windir%\system32\DirectX\DXWebSetup.exe /c:”DXwSetup.exe /windowsupdate” /q /r:n

Exit

Let that one rip and ……. AutoCAD 2010 installs like a dream!!

Kinda. Well, until you try to run it and then you get an error message stating: “adui18res.dll no found”

Damn.

Watch out for part 3 when I tackle that particular issue!

Edit: After further testing it seems the script needs to hang on for a bit whilst DirectX finishes the download and install. To make it do this, simply add “start /wait” to the front of the line running dxwebsetup.exe and the PC will launch it as a seperate process and wait until it terminates before moving on.

Posted in IT | Tagged: , , , , | Leave a Comment »