Ramblings From The Litter Tray of Life

Deploying AutoCAD 2010 via GPO (Part 2)

Posted by graycat on 9 June 2009

Carrying on from my previous post on deploying AutoCAD 2010 via GPO here’s an update with the latest problems and solutions I’ve run into.

AutoCAD LT  deploys fine now. I think after the scripted installs had finished doing their thing, it was happy. Since then all the deployments have gone through fine including those on live machines. Now it’s all down to the CAD guys to let me know how it works.

I’ve since rolled up my sleeves and am taking a swing at the bigger one with the full fixed licence install.

The installation package went up to the server / dfs share fine as you would expect but my god it’s huge! 1.4Gb to be slightly more accurate!! Ok, so that is with all the packages included but it’s still a touch large in my opinion. The price of progression and all that.

So post package upload I was looking through it and it claims to have the C++ package embedded so I decided to leave my own package off at this point and see how it rolls. I created the new GPO, security group, wiped the test rig and linked it all together.

Unfortunately it failed.

DirectX – error message  saying “must install DirectX first” was he only indicator which was a bit frustrating as DirectX was already installed! A quick test using “dxdiag” confirmed it was there but the install package was just not having it.

Looking into deploying DirectX showed some interesting approaches out there. A quick try of a few and the most reliable one was using the web setup. To do this you need to download the dwebsetup.exe from Microsoft and then setup a nice startup script to actually run the install. Here’s mine:

REM    Check if dxwebsetup.exe exists already
if exist %windir%\system32\DirectX\DXWebSetup.exe exit else

REM     make folder and copy down base installer
md %windir%\system32\DirectX

xcopy /c/y \\domain\dfs\it\deployment\directx\dxwebsetup.exe %windir%\system32\DirectX\

REM     install DirectX
%windir%\system32\DirectX\DXWebSetup.exe /c:”DXwSetup.exe /windowsupdate” /q /r:n

Exit

Let that one rip and ……. AutoCAD 2010 installs like a dream!!

Kinda. Well, until you try to run it and then you get an error message stating: “adui18res.dll no found”

Damn.

Watch out for part 3 when I tackle that particular issue!

Edit: After further testing it seems the script needs to hang on for a bit whilst DirectX finishes the download and install. To make it do this, simply add “start /wait” to the front of the line running dxwebsetup.exe and the PC will launch it as a seperate process and wait until it terminates before moving on.

Advertisements

Leave a Reply

Please log in using one of these methods to post your comment:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: